<?xml version="1.0" encoding="UTF-8"?>
  <?xml-stylesheet type="text/xsl" href="rfc2629.xslt" ?>
  <!-- generated by https://github.com/cabo/kramdown-rfc version 1.7.43 (Ruby 4.0.6) -->


<!DOCTYPE rfc  [
  <!ENTITY nbsp    "&#160;">
  <!ENTITY zwsp   "&#8203;">
  <!ENTITY nbhy   "&#8209;">
  <!ENTITY wj     "&#8288;">

<!ENTITY RFC1035 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.1035.xml">
<!ENTITY RFC4648 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4648.xml">
<!ENTITY RFC3597 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.3597.xml">
<!ENTITY RFC7493 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7493.xml">
<!ENTITY RFC2119 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2119.xml">
<!ENTITY RFC8174 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8174.xml">
<!ENTITY RFC7208 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7208.xml">
<!ENTITY RFC8552 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8552.xml">
<!ENTITY I-D.kowalik-domainconnect SYSTEM "https://bib.ietf.org/public/rfc/bibxml3/reference.I-D.kowalik-domainconnect.xml">
]>


<rfc ipr="trust200902" docName="draft-hoffman-duj-06" category="std" consensus="true" submissionType="IETF">
  <front>
    <title abbrev="DNS Update with JSON">DNS Update with JSON</title>

    <author initials="P." surname="Hoffman" fullname="Paul Hoffman">
      <organization>ICANN</organization>
      <address>
        <email>paul.hoffman@icann.org</email>
      </address>
    </author>

    <date year="2026" month="September" day="26"/>

    
    
    

    <abstract>


<?line 35?>

<t>It is common for service providers such as certificate authorities and social media providers to want users to update the users' zones to prove that they control those zones, or to add other features.
Currently, service providers tell users to do this using human language describing the resource record type and data values to enter into the zone.
This document describes a text format, called "DNS update with JSON" or "DUJ", for such a service provider to give to a user, with the expectation that the user would copy and paste the text to their DNS operator to update the user's zone.
DNS operators who know how to handle DUJ strings will make the update process easier and more predictable for their users.</t>



    </abstract>



  </front>

  <middle>


<?line 42?>

<section anchor="introduction"><name>Introduction</name>

<t>There are many scenarios where someone gives instructions to a human to update their DNS zone in order to prove that they control those zones, or to add other features.
For example, someone suggesting that you add an SPF <xref target="RFC7208"/> record to a zone might say "add a TXT record with the value "v=spf1 a:mail.yourname.example ip4:192.0.2.49" to your zone".
The expectation is that you are either able to edit your zone file directly and understand the format of the records, or you use a DNS operator who has an interface for you to be able to add and modify records in your zone.</t>

<t>This document proposes a method for giving a human a string that can be copy-and-pasted to give a precise update for a zone.
The protocol, called "DNS update with JSON" or "DUJ", specifies a string format in I-JSON <xref target="RFC7493"/> that represents the addition and deletion of records in a DNS zone.
It is designed for DNS operators who accept strings in their interface for zone updates.
The format self-identifies a string as DUJ, and the protocol lists what is and is not acceptable for DUJ strings.
Using DUJ makes the update process more reliable for DNS operators and their users.</t>

<section anchor="use-case"><name>DUJ Use Case</name>

<t>DUJ is specifically targeted at improving the current common scenario of a user being told by an application service or a helpful friend to modify their DNS zone.
DUJ is not intended for any automatic zone updates.
DUJ is intended only for users who copy-and-paste.</t>

<t>There are two types of DUJ strings: DUJS and DUJ64.
DUJS strings can be typed by users, but doing so can easily introduce errors that might negatively affect their DNS zone.
DUJ64 strings cannot be safely typed by users.</t>

<t>There is no intention in the design for the user to change the text in a DUJ string.
Because DUJ strings contain quoted text, and some typing systems might automatically unhelpfully convert quotation marks into "smart quotes", for some users typing DUJ strings might be impossible.</t>

<t>Different, more elaborate protocols for automatic updates, may be proposed separately.
For example, DomainConnect (<xref target="DomainConnect"/>, <xref target="I-D.kowalik-domainconnect"/>) defines an automated protocol that includes user affirmation before updates.
DUJ is purposely more limited and less ambitious than those protocols, with the assumption that it will be much easier to deploy.
Service providers might allow manual updates as they do today, manual updates by DUJ, and automated updates with a protocol like DomainConnect.</t>

</section>
<section anchor="design"><name>DUJ Design</name>

<t>This format is explicitly only meant for the use cases in <xref target="use-case"/>.
If the designer of an automated protocol is thinking of re-using DUJ in that protocol, they should not.
DUJ is specifically designed for copy-and-paste by end users.
It would be trivial to design a better format for describing automated DNS updates.</t>

<t>The design choice to use JSON arrays instead of objects is to increase security and reliability.
This is to prevent key-value pairs to be added that might cause users or operators to possibly process the DUJ strings incorrectly or to misinterpret them.
For example, it is not possible to include comments in a DUJ string such as "For DKIM".
The reason for this is that such comments could be used by an attacker to convince a user to make a change that they otherwise might not by adding a comment such as "Urgent security update".</t>

<t>DUJS strings are meant to be somewhat readable by the user.
They might not understand what it says, but if they understand something about the DNS, they might.
For example, you might see that a particular RRtype and Rdata are proposed to be added to your zone by looking at the DUJ string you are presented.</t>

<t>DUJ64 strings are purposely not readable by the user.
However, the user can still see if records are being added or deleted.</t>

<t>DUJ strings should not be difficult for a service to create.
There are cases described later where the quoting on the Rdata field can be tricky, but forcing an application to understand backslash quoting and apply it correctly is considered out of scope for a format this is only meant to replace human-readable instructions like "enter this record into your zone".</t>

<t>This document assumes that the application service will have looked in the user's zone before suggesting a zone update.
That would likely be true in the current use case where the application service suggests an update to the user's zone.</t>

<t>Another explicit design for DUJ is that it is not extensible.
If there is a reason to create a later version, the first string ("DJUS" or "DUJ64") can be changed to one that includes a new version identifier.</t>

<t>During the development of DUJ, there was a suggestion that each action string be followed by a list of record-data for that action.
For example, to add two records, there would be only one action template of "add", which has two records.
This suggested was rejected because it complicates the processing while saving only a tiny amount of space.</t>

</section>
<section anchor="bcp-14-language"><name>BCP 14 Language</name>

<t>The key words "<bcp14>MUST</bcp14>", "<bcp14>MUST NOT</bcp14>", "<bcp14>REQUIRED</bcp14>", "<bcp14>SHALL</bcp14>", "<bcp14>SHALL
NOT</bcp14>", "<bcp14>SHOULD</bcp14>", "<bcp14>SHOULD NOT</bcp14>", "<bcp14>RECOMMENDED</bcp14>", "<bcp14>NOT RECOMMENDED</bcp14>",
"<bcp14>MAY</bcp14>", and "<bcp14>OPTIONAL</bcp14>" in this document are to be interpreted as
described in BCP 14 <xref target="RFC2119"/> <xref target="RFC8174"/> when, and only when, they
appear in all capitals, as shown here.</t>

<?line -18?>

</section>
</section>
<section anchor="specification"><name>Specification</name>

<t>An example of a DUJS string is:</t>

<figure><artwork><![CDATA[
[ "DUJS", [ ["add", "mail.yourname.example TXT \"v=spf1 a:mail.yourname.example ip4:192.0.2.49\""] ] ]
]]></artwork></figure>

<t>An example of a DUJS string is:</t>

<figure><artwork><![CDATA[
[ "DUJ64", [ ["add", "bWFpbC55b3VybmFtZS5leGFtcGxlIFRYVCAidj1zcGYxIGE6bWFpbC55b3VybmFtZS5leGFtcGxlIGlwNDoxOTIuMC4yLjQ5Ig=="] ] ]
]]></artwork></figure>

<t>A DUJ string <bcp14>MUST</bcp14> be a JSON array with two values. The first value is the string "DUJS" or "DUJ64".
The second value is an array, called the "update array", which lists all the updates.
The update array <bcp14>MUST</bcp14> have a length of at least 1.</t>

<t>The arrays in the update array are called "action templates".
Every action template is exactly two values: "action" and "record-data".</t>

<t>The action is a string specifying the action to be taken.
The action string <bcp14>MUST</bcp14> be either "add" or "delete"; no other values are allowed.</t>

<t>The record-data is a string that is in the zone file format defined in <xref target="RFC1035"/>.
The record-data <bcp14>MAY</bcp14> contain class names, as described in <xref target="RFC1035"/>.
The record-data <bcp14>MAY</bcp14> contain time-to-live (TTL) values, as described in <xref target="RFC1035"/>.</t>

<section anchor="dujs"><name>DUJS</name>

<t>The record-data in DUJS strings <bcp14>MUST NOT</bcp14> include zone file comments, directives, or embedded newlines from <xref target="RFC1035"/>.
The record-data in DUJS stings <bcp14>MAY</bcp14> contain \DDD and \X escapes, and parentheses, from <xref target="RFC1035"/>.</t>

</section>
<section anchor="duj64"><name>DUJ64</name>

<t>A DUJ64 string is identical to a DUJS string except that the record-data in a DUJ64 string is the Base64 <xref target="RFC4648"/> encoding of he record-data that would have gone into a DUJS string.</t>

</section>
<section anchor="notes-on-owner-names"><name>Notes on Owner Names</name>

<t>The owner name of a zone in a record-data string might be a name that does not yet exist because it is being created by an "add" action.
A common example of this is adding an "underscore name" <xref target="RFC8552"/> such as "_smimecert" and "_xmpp".
A DNS operator would have to determine whether the full owner name given in the record-data could be created, which might not be possible due to zone cuts.</t>

<t>The owner-name <bcp14>MUST NOT</bcp14> contain a wildcard.</t>

</section>
<section anchor="notes-on-rrtypes"><name>Notes on RRtypes</name>

<t>The RRtype in the record-data with the name of the resource record type for the action.
The RRtype's name is given in the "TYPE" column of the "Resource Record (RR) TYPEs" IANA registry <xref target="Types-registry"/>.</t>

<t>To specify an RRtype that is not yet in the registry, use the format specified in <xref target="RFC3597"/>.
For example:</t>

<figure><artwork><![CDATA[
["DUJS", [ ["add", "yourname.example TYPE4321 \# 4 0A000001"] ] ]
]]></artwork></figure>

</section>
</section>
<section anchor="processing"><name>Processing</name>

<t>This section defines rules for DNS operators who allow updates with DUJ to process DUJ strings they receive.</t>

<t>The update array is an ordered list of action templates.
The DNS operator <bcp14>MUST</bcp14> process each action template in the order it appears in the update array.
However, the DNS operator does so only after verifying that the entire DUJ string can be atomically applied to the target zone.
The DNS operator <bcp14>MUST NOT</bcp14> process any action within the DUJ if any action would prevent the atomic application of the entire DUJ string.</t>

<t>The DNS operator <bcp14>MAY</bcp14> choose to skip an "add" action if it would create a record that is already in the zone.
The DNS operator <bcp14>MAY</bcp14> choose to skip a "delete" action if it would delete a record that did not exist in the zone.</t>

<t>The DNS operator <bcp14>SHOULD</bcp14> be able to handle <xref target="RFC3597"/> RRtypes.
However, they may have a local policy to not allow users to add or delete unknown RRtypes.</t>

<t>A DNS operator <bcp14>MAY</bcp14> reject any DUJ string for any reason, such as if it adds and then deletes the same record.
If the DUJ was received from a user interface, the DNS operator <bcp14>SHOULD</bcp14> clearly describe why a DUJ was rejected.</t>

<section anchor="string-verification"><name>String Verification</name>

<t>The DNS operator <bcp14>MUST</bcp14> not process any DUJ string where any of the following rules are not met:</t>

<t><list style="symbols">
  <t>The DUJ string <bcp14>MUST</bcp14> be valid I-JSON.</t>
  <t>The first element of the DUJ string <bcp14>MUST</bcp14> be "DUJS" or "DUJ64".</t>
  <t>The update array <bcp14>MUST</bcp14> have at least one action template.</t>
  <t>Every action template <bcp14>MUST</bcp14> meet the following rules:
  <list style="symbols">
      <t>The action element <bcp14>MUST</bcp14> be either the exact string "add" or "delete"</t>
      <t>The FQDN <bcp14>MUST</bcp14> be a valid fully-qualified domain name</t>
      <t>The FQDN <bcp14>MUST NOT</bcp14> contain a wildcard</t>
      <t>The RRtype <bcp14>MUST</bcp14> be recognized, or be in the format specified in <xref target="RFC3597"/></t>
      <t>The Rdata <bcp14>MUST</bcp14> be appropriate for the given RRtype</t>
    </list></t>
</list></t>

</section>
<section anchor="action-processing"><name>Action Processing</name>

<t>After verifying the DUJ string, the DNS operator processes each action template in order.
When processing an action template, the DNS operator <bcp14>MUST</bcp14> verify:</t>

<t><list style="symbols">
  <t>that the user is authorized to change the zone named in the FQDN</t>
  <t>that, for "delete" actions, that the exact record described in the action template exists</t>
  <t>that, for "add" actions, that the exact record described in the action template does not already exist</t>
</list></t>

<t>A DNS operator <bcp14>SHOULD</bcp14> tell a user about every change made from a DUJ.</t>

</section>
</section>
<section anchor="iana-considerations"><name>IANA Considerations</name>

<t>This document contains no actions for IANA.</t>

</section>
<section anchor="security-considerations"><name>Security Considerations</name>

<t>A DUJ has no cryptographic protection.
It is, by design, only as secure as the current common scenario where a service tells a user to manually copy and paste some data (the RRtype and Rdata values) into an interface run by the DNS operator.</t>

<t>When a service gives the user a DUJ string, the authenticity of the source of the DUJ string and the integrity of the DUJ string is only as strong as the user's connection to the service.
When a user pastes a DUJ string to a DNS operator, the authenticity of the source of the DUJ string and the integrity of the DUJS is only as strong as the user's connection to the DNS operator.</t>

</section>


  </middle>

  <back>


<references title='References' anchor="sec-combined-references">

    <references title='Normative References' anchor="sec-normative-references">

&RFC1035;
&RFC4648;
&RFC3597;
&RFC7493;
&RFC2119;
&RFC8174;


    </references>

    <references title='Informative References' anchor="sec-informative-references">

&RFC7208;
&RFC8552;
&I-D.kowalik-domainconnect;
<reference anchor="DomainConnect" target="https://www.domainconnect.org/">
  <front>
    <title>DomainConnect</title>
    <author >
      <organization></organization>
    </author>
    <date />
  </front>
</reference>
<reference anchor="Types-registry" target="https://www.iana.org/assignments/dns-parameters/">
  <front>
    <title>Domain Name System (DNS) Parameters</title>
    <author >
      <organization></organization>
    </author>
    <date />
  </front>
</reference>


    </references>

</references>


<?line 240?>

<section anchor="acknowledgements"><name>Acknowledgements</name>

<t>Andy Newton,
Bob Harold,
Gavin Brown,
Jasdip Singh,
John Levine,
Libor Peltan,
Pawel Kowalik,
Peter Tomassen,
and
Robert Edmonds
contributed substantial comments to early versions of this draft.</t>

</section>


  </back>

<!-- ##markdown-source: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-->

</rfc>

